Results 1 to 9 of 9

Thread: All things HOTAS

  1. #1

    Default All things HOTAS

    It's inevitable. At some point you're going to have to have a HOTAS to fly. Some folks say they can fly with the keyboard. I say rubbish!

    When I quit flying in 2011, I liquidated my x52Pro and Headset figuring I'd never need them again. Then, last week, after some ridiculous pestering by Deacon, I decided to begin some "casual" flying again. So, first up was to find another stick. Bang...done. A used x52Pro arrived yesterday. I checked it out and found it was in really shape, good spring, good, firm action.

    So, I plugged it all up and then popped the USB plug into an available port. Now understand, the last time I did this was in MS WinXP Pro. Now it was MS Win10 Pro. What happened? Nothing.....absolutely nothing. What should have happened was Win should have noticed a new device had been plugged in and begin a device driver install. I checked Harware and Devices...nothing. I check all the control file settings....nothing. I dove into all the USB HID settings....nothing. So, I jumped over to Saiteks site, downloaded the drivers and software. I then executed the driver install.....hang.....nothing. I searched the forum and found instructions for manually installing the drivers....didn't work.

    Two hours later, stumped and confused, I reboot my rig to restart the process, and wonder of wonders, Win10 found the HOTAS and installed the drivers automatically. Who knew....

    It was pretty late for an old fart like me, so I called it for the night. Tonight, I'll configure the stick, so stay tuned to this thread to follow along.
    "War has a grim purpose and is extremely complex. Sophisticated planning and doctrine are present at every level. Yet at the point of fire battle is the essence of chaos and violence."

  2. #2


    Oscar, there's an issue in Windows 10 with USB ports and M$'s energy saving settings. The result is that the ports will shut down and the stick (or whatever you have plugged into them, will stop working. The problem raised its ugly head when I tried to install my Warthog in Windows 10. The only fix I'm aware of is to manually edit the registry to disable the energy saving process. I have an email somewhere describing the issue and the fix.

    There is also a more basic problem; most HOTAS systems work best (or at all) in USB 2.0 ports and most computers now have both USB 2 and USB 3 ports. If you try and use or install a stick in a USB 3 port you'll run into nothing but problems; in my case my Warthog wouldn't install at all. However, I put it in a USB 2 port and voila, installation went smoothly and the problem was resolved.


    Ahh, isn't he such an Angel?
    How could you possibly shoot at him?

  3. #3


    Well, that explains a lot......
    "War has a grim purpose and is extremely complex. Sophisticated planning and doctrine are present at every level. Yet at the point of fire battle is the essence of chaos and violence."

  4. #4


    For those that have the Warthog, I have noticed something that is very annoying. The action on my stick just isn't smooth. There are little glitches in the movement that is driving me crazy. I have looked into it and have found that this is a common occurrence with the Warthog. If you are Warthog owners and are experiencing the same thing look here. and here

    I had the same problems with my Saitek 52 and 55 and resolved that problem by applying white lithium grease to the shaft that the inverted cone slides up and down on. It made all the difference and smoothed out the little small control inputs needed to fly smoothly.


    "The most important branch of aviation is pursuit, which fights for and gains control of the air"
    U.S. Brigadier General William Mitchell

  5. #5


    Here is a portion of an email I sent to the Group explaining the Windows 10 issue(s) as it/they relate to peripherals like joysticks (or almost any peripheral, really):

    Windows 8, 8.1, and 10 have an "enhanced" power management addition to USB ports that earlier versions of Windows, including Windows 7, did not have. M$ is trying, I suspect, to do "the right thing" but in doing so they are definitely screwing up older peripherals, particularly gaming peripherals like joysticks and rudders. I doubt if M$ cares much since they are much more interested in selling consoles than enabling PCs to be good gaming platforms (if they cared about the latter Windows 10 would be a very different OS, IMHO).

    What does the "Enhanced Power Management" aspect of USB ports mean to us? In a nutshell it means that USB ports no longer receive constant full power; Windows 10 shuts the power down to ports, even they are in use, in an effort to "save battery life" (M$'s words, not mine). You know, save the life of the batteries powering your PC! Oh, you don't have battery power on your PC? Apparently M$ thinks all PCs are laptops, seriously.

    Can you "adjust" the "Enhanced Power Management" for your USB ports? Yes, but not easily. "Well, if I don't adjust EPM, what will happen?" That's a fair question. In my case, my Wart Hog wouldn't upgrade firmware during a driver install and I was actually afraid, since the firmware upgrade halted mid-stream, that I'd damaged my joystick. Fortunately things weren't that dire. Once I turned "off" EPM I was able to complete the driver and firmware install and my Warthog is now fully functional, but before then it, and its software, simply wouldn't work.

    That's not a Thrustmaster issue alone ..... the problem will surface with ANY USB device that requires any significant amount of power to operate. "Well, how do I fix it?" Hold on a minute, I'm getting to that.

    Hand in hand with EPM goes an issue with USB 2 and USB 3 which is not really a OS-caused problem, but it might as well be from a "fixing it" perspective. USB 3 is the newer standard and has a much faster data transfer rate than the older USB 2. As my ASUS board documentation clearly states, USB 3 ports are for data transfer, USB 2 ports are for older peripherals. I blew that statement off thinking that faster is always better, but for peripherals like joysticks and rudder pedals that thinking isn't necessarily correct. Lesson learned; put the gaming peripherals in USB 2 ports. If you need to get a powered hub, get it, but stick with USB 2 and save a lot of headaches.

    Also note that the age of your system's mainboard and chipset will impact how serious the latter issue (of 2 vs 3) is; older systems may not even have USB 3 hence not the problem. My new board has three times the usb 3 ports that it does 2 (it has only 2 ports of USB2), so the problem is real with some new boards. But ALL USB ports, 2 and 3, suffer from the EPM issue.

    So, how do I fix it? It's a complicated procedure involving manually editing the registry, and then only the *correct* registry entries. Manual editing of the registry is *always* hazardous, but it CAN be done safely if one is careful. Here's how I did it:

    I use a program called USBDEVIEW. Using it I can plug in my joystick and rudders into a USB port and, in usbdeview, see in what USB port each is. The screen, on the far right of each line for each USB port, in a column entitled "Instance ID", shows the hardware identifier for each. If you right click on the hardware identifier there is a selection entitled "Open in RegEdit". Selecting that option opens RegEdit to the proper place (it should open to Device Parameters, if not do so). The entry that needs a change is "EnhancedPowerManagementEnabled"; change the value from "1" to "0" to turn it off. You can read M$'s description here.

    If you don't see that line either you're in the wrong place or your peripheral isn't plugged in.

    This EPM issue also affects charging of USB devices; if you plug in a phone for example you might find that it won't charge, or charge for only a short time but not completely. The culprit is the EPM entry for the port you are using.

    And yes, you need to take these steps for each port you use.

    Ahh, isn't he such an Angel?
    How could you possibly shoot at him?

  6. #6


    When I read your previous email about the USB2 vs 3 problem, I figured it would affect a number of things, simulation wise. So I got online with Amazon and ordered a USB 2.0 four port hub for a mere 6.29. I just turned one 2.0 port into 4. If that doesn't seem to work well enough, I'll just get an add-on board that plugs directly into my MB as I did with a 3.0. easy peasy

  7. #7


    So ........ why am I so reluctant to spend more time with DCS? The major reason is that it is ROYAL PAIN IN THE ASS (RPIA) to go through the set-up of controls, particularly when the control data file is not an .ini or other text file, but a .xml file hiding behind the label ".lua". Who the hell knows what that is??

    I don't give a shite about a .lua file; I want to be able to set up my Warthog with TARGET software; in IL-2 I was fairly quickly able to figure out how to do it, notwithstanding that the result was more than a bit different than the output of the earlier FOXY software. But it worked, and I figured out (largely) how to use the TARGET software to "macro-ize" the key inputs. DCS? No stinkin' way.

    Anyhow, just this afternoon I stumbled across this posting that showed me the way and, of not every question, answered enough, with clear enough explanations, to point me in the right direction.

    Now, to use the education to my benefit ................ well, at least to the benefit of my ability to fly the damned plane!
    Last edited by 352nd Persecutor; 01-08-2017 at 08:29 AM.

    Ahh, isn't he such an Angel?
    How could you possibly shoot at him?

  8. #8


    For X52 Pro users:

    1. When programming with the saitek software and not in DCS, make sure your MODE switch on the stick is in the right place! I did a bunch of programming, loaded the profile, jumped into DCS, nothing worked!! Why? Because I programmed all the stuff on MODE 2 by mistake, but tried to fly in MODE 1.....duh! Took quite a while to fix that.

    2. Rotaries are a B1TCH! I've spent a lot of time trying to get the band %'s just right for my rudder, elevator and aileron trims. Still working this until I get it like I want it, but it is frustrating.

    3. Throttle throw is an issue right now. The physical throttle action is from 0-100, but, in game, I only need to idle get a good green Manifold Pressure when pitch is adjusted for the green instead of a 50% throttle setting . I'm thinking I need to look at this is from within DCS and I need to adjust the config there....we'll see.

    Obviously, some of these can be detrimental. Remember, I haven't flown in what, 6 years! Case in point:

    1st landing...... bouncy, bouncy, bouncy.... crash. LoL.
    2nd landing...... rinse, repeat.....
    3rd landing...... skinned up the wing tips, ground rolled, but walked away....
    4th landing..... nosed it...duh. A little to heavy on the brakes....
    5th landing..... now we're talkin..... pilot and plane safe, but in the grass....

    All of these issues were "throttle" related. Very difficult getting down to a landing speed then you set the flaps full and the throttle zeroed, yet, you're still pushing 150.... and that's with a looooong approach!

    In the air.... I can cruise and do aerobatics like a genius.....

    Anyways, the testing and configuring continues... just though I'd post some of the things I've been going through related to HOTAS for others to know that they are not in the the boat by themselves.....
    "War has a grim purpose and is extremely complex. Sophisticated planning and doctrine are present at every level. Yet at the point of fire battle is the essence of chaos and violence."

  9. #9



    Pers: Thanks for the USBDEVIEW tip. After a small Win10 learning curve on my part, the program worked as advertised.
    "War has a grim purpose and is extremely complex. Sophisticated planning and doctrine are present at every level. Yet at the point of fire battle is the essence of chaos and violence."

Similar Threads

  1. Things that are "lost"
    By wheelsup_cavu in forum General Comments
    Replies: 3
    Last Post: 04-03-2016, 09:17 PM
  2. Things to fix
    By wheelsup_cavu in forum Wish List
    Replies: 3
    Last Post: 03-13-2015, 01:21 PM
  3. Newest map or things to come
    By 352nd_Deacon in forum General Comments
    Replies: 23
    Last Post: 05-25-2008, 01:50 PM
  4. A Taste of Things to Come .........
    By 352nd Persecutor in forum General Comments
    Replies: 17
    Last Post: 03-24-2008, 02:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts